Easyelectronics.ru

Электроника для всех
Текущее время: 22 сен 2019, 19:38

Часовой пояс: UTC + 5 часов



JLCPCB – Прототипы печатных плат за $2/10pcs (Любой цвет!)
Крупнейший производитель печатных плат и прототипов. Более 600000 клиентов и свыше 10000 заказов в день!
Получите скидку на почтовую отправку при первом заказе в JLCPCB!

Начать новую тему Ответить на тему  [ Сообщений: 5 ] 
Автор Сообщение
 Заголовок сообщения: Новый проект в Keil
СообщениеДобавлено: 10 янв 2015, 21:35 
Только пришел

Зарегистрирован: 13 дек 2014, 19:00
Сообщения: 18
Начал изучать Pinboard II, подключил плату, откомпилировал и загрузил пример из "Быстрый старт. ARM". Пока игрался в этом проекте, все было хорошо, но когда попробовал создать новый проект по "ARM. Учебный Курс. Keil + CMSIS. Создание проекта", обнаружил, что Keil не видит отладчик. Опытным путем установил, что в тестовом примере за это "отвечает" файл "GPIO_RTOS_CMSIS_STM32.dep", но во вновь создаваемом проекте подобного файла нет. Пробовал четвертую и пятую версии Keil - результат один и тот же. Собственно вопрос - что нужно сделать, чтобы Keil работал с отладчиком при создании проекта с нуля?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Новый проект в Keil
СообщениеДобавлено: 10 янв 2015, 21:38 
Администратор
Аватара пользователя

Зарегистрирован: 16 янв 2010, 06:09
Сообщения: 6273
Откуда: Челябинск
Надо зайти в настройки проекта и там в разделе Дебаг выставить все точно также как и в готовом проекте.

_________________
Хозяин дома


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Новый проект в Keil
СообщениеДобавлено: 10 янв 2015, 23:16 
Только пришел

Зарегистрирован: 13 дек 2014, 19:00
Сообщения: 18
DI HALT писал(а):
Надо зайти в настройки проекта и там в разделе Дебаг выставить все точно также как и в готовом проекте.


Там все установлено, я уже все опции проекта сравнивал постранично - всё совершенно одинаково, но в тестовом проекте отладчик видит подключенную плату, а в новом - никак (нет IDCODE и Device Name).


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Новый проект в Keil
СообщениеДобавлено: 11 янв 2015, 05:32 
Администратор
Аватара пользователя

Зарегистрирован: 16 янв 2010, 06:09
Сообщения: 6273
Откуда: Челябинск
В том числе и настройки дебагера, выбранный отладчик, сценарии загрузки флеша?
http://easyelectronics.ru/img/snap/2015 ... 9_snap.png
http://easyelectronics.ru/img/snap/2015 ... 2_snap.png

_________________
Хозяин дома


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Новый проект в Keil
СообщениеДобавлено: 11 янв 2015, 12:28 
Только пришел

Зарегистрирован: 13 дек 2014, 19:00
Сообщения: 18
Да, всё это настроено, но на вкладке Debug написано "No support device found". Если тут же загрузить тестовый проект - всё нормально. Еще выяснил, что если из тестового проекта исключить файл GPIO_RTOS_CMSIS_STM32.dep, то и с ним Keil перестает видеть плату.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 5 ] 

Часовой пояс: UTC + 5 часов


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB