Easyelectronics.ru

Электроника для всех
Текущее время: 22 сен 2019, 13:27

Часовой пояс: UTC + 5 часов



JLCPCB – Прототипы печатных плат за $2/10pcs (Любой цвет!)
Крупнейший производитель печатных плат и прототипов. Более 600000 клиентов и свыше 10000 заказов в день!
Получите скидку на почтовую отправку при первом заказе в JLCPCB!

Начать новую тему Ответить на тему  [ Сообщений: 10 ] 
Автор Сообщение
 Заголовок сообщения: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 22:30 
Только пришел

Зарегистрирован: 07 апр 2013, 11:07
Сообщения: 6
Прикрутив к ECLIPSE msp430plugin (WinXp/Win7) http://xpg.dk/projects/msp430/msp430-eclipse/
я никак не могу прикурить утилиту "mspdebug" - http://mspdebug.sourceforge.net/manual.html.
Она не видит ни MSP-FET430UIF (пробовал 2 прошивки и обе из соответствующих IARов работают), и
LaunchPad- тоже самое.

на запрос
mspdebug.exe -j uif
ответ
MSPDebug version 0.20 - debugging tool for MSP430 MCUs
Copyright (C) 2009-2012 Daniel Beer <dlbeer@gmail.com>
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

usbutil: unable to find a device matching 0441:f430

Хотя в диспетчере win7: USB\VID_0451&PID_F430&REV_0101
Подскажите если есть соображения.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 22:40 
Старожил

Зарегистрирован: 03 мар 2010, 14:10
Сообщения: 1514
Откуда: Беларусь, Минск
Я использую mspdebug с драйвером tilib. Но для этого прошивка адаптера и библиотека должны соответствовать друг другу. Самый просто способ достичь этого - обновить прошивку адаптера при помощи mspdebug.
http://mspdebug.sourceforge.net/tilib.html


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 22:49 
Только пришел

Зарегистрирован: 07 апр 2013, 11:07
Сообщения: 6
Установил настройку в tilib дебаггер запускается но отладка не доступна это - из-за прошивок?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 22:55 
Старожил

Зарегистрирован: 03 мар 2010, 14:10
Сообщения: 1514
Откуда: Беларусь, Минск
[телепат]Фаза луны, когда написана была mspdebug, не совпадает с нынешней[/телепат]


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 23:30 
Только пришел

Зарегистрирован: 07 апр 2013, 11:07
Сообщения: 6
Спасибо за быструю помощь.
Обновил прошивку той которая в тулчейне. Теперь показывает дизассемблер. Делаю один шаг и опять куда-то всё вылетает(окно дизассемлера пустое становится - No debug context). Мож контроллер слишком наверченный (F2618)?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 09 апр 2013, 23:56 
Старожил

Зарегистрирован: 03 мар 2010, 14:10
Сообщения: 1514
Откуда: Беларусь, Минск
Может у вас нету обработчика прерывания, а само прерывание разрешено? Но это лишь догадка. Исходя из "откуда улетело" и "куда улетело" можете попробовать восстановить причину.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 10 апр 2013, 20:24 
Только пришел

Зарегистрирован: 07 апр 2013, 11:07
Сообщения: 6
Нет. Програмулина из 3-х строк:
#include <msp430.h>
int main(void)
{
WDTCTL = WDTPW + WDTHOLD;
for(;;);
return 0;
}
и не работает отладка в режиме tilib.

На 3-ю версию прошивки тоже переходил -> tilib режим вообще перестал работать.
Уважаемый AMX не могли-бы Вы сообщить конкретно работающие версии прошивок, mspfebug и драйверов.
(Очень хочется перейти на Eclipse+mspdebug)


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 10 апр 2013, 22:40 
Старожил

Зарегистрирован: 03 мар 2010, 14:10
Сообщения: 1514
Откуда: Беларусь, Минск
Эклипс не пробовал. У меня mspdebug-0.20 и libmsp430-3.2.5.4 (slac460e, UIF Firmware version is 30205004). Всё это работает под GNU/Linux. Отладку через gdb не пробовал, но из консоли mspdebug шагает по инструкциям исправно.
Прошивку обновлял по инструкции http://mspdebug.sourceforge.net/tilib.html#fet_firmware


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 11 апр 2013, 06:40 
Только пришел

Зарегистрирован: 07 апр 2013, 11:07
Сообщения: 6
Спасибо за ответ. Буду пробовать.Но что-то мне подсказывает что дело в винде.(Я из под линукса не пробовал)


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема MSPDEBUG
СообщениеДобавлено: 07 сен 2018, 14:59 
Старожил

Зарегистрирован: 17 сен 2013, 13:53
Сообщения: 3302
Побуду некромансером.

Закачал у техасцев новый тулчейн, уже на gcc 7, соответсвенно системный дебиановский (Debian 9) mspdebug прошивать прошивает, но вот в отладке на брекпойнте не стопорится. Если скачать и скомпилить свежак с гитхаба, то все работает.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 10 ] 

Часовой пояс: UTC + 5 часов


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB