Easyelectronics.ru

Электроника для всех
Текущее время: 27 фев 2017, 14:24

Часовой пояс: UTC + 5 часов



    • Изготовление печатных плат
    • Создание принципиальных схем и проектирование печатных плат
    • Симуляция работы на spice моделях
    • Просмотр GERBER файлов

Начать новую тему Ответить на тему  [ Сообщений: 12 ] 
Автор Сообщение
 Заголовок сообщения: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 25 янв 2015, 01:06 
Здравствуйте!

Зарегистрирован: 25 янв 2015, 00:56
Сообщения: 3
Добрый день!
Прошу подсказать, если найдется время))))
Приобрел программатор(клон): ссылка
Однако никак не могу заставить его работать с последней (6.2) Atmel Studio.

У меня Win 7, 64-bit
Atmel Studio 6 (Version: 6.2.1502 - Service Pack 1)

При запуске Tools>Device Programming выбираю Tool:AVRISP mkII, Device: ATmega16A, Interface: ISP
и получаю ошибку:
Unable to connect to tool AVRISP mkII (000200212345)
Куда идти дальше не пойму...


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 25 янв 2015, 02:08 
Старожил

Зарегистрирован: 20 мар 2013, 11:27
Сообщения: 4229
FrChKrueger писал(а):
Куда идти дальше не пойму...


вполне возможно, что только откатываться на xp 32 бит и возможно старую студию

атмел недавно обновил 64-битный драйвер для студии чтобы работало под 8.1
вполне возможно клон с новым драйвером не заработает

а кстати пакет Atmel USB стоит? может все как раз наоборот и нужно поставить новый драйвер


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 25 янв 2015, 02:14 
Здравствуйте!

Зарегистрирован: 25 янв 2015, 00:56
Сообщения: 3
axill писал(а):
FrChKrueger писал(а):
Куда идти дальше не пойму...


вполне возможно, что только откатываться на xp 32 бит и возможно старую студию

атмел недавно обновил 64-битный драйвер для студии чтобы работало под 8.1
вполне возможно клон с новым драйвером не заработает

а кстати пакет Atmel USB стоит? может все как раз наоборот и нужно поставить новый драйвер


Atmel USB стоит, клон определяется правильно в системе (ну в смысле по имени), но работать отказывается.
Грусть, печаль...
Версия драйвера вроде от 26.01.14.

А если все так с Win7, чем же прошивать контроллеры? Ну если нет у меня компа с XP?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 25 янв 2015, 02:40 
Старожил

Зарегистрирован: 20 мар 2013, 11:27
Сообщения: 4229
ну насчет клона если честно я не в курсе
у меня оригинальный мк2, и я имел с ним проблему осенью на 8.1 пока не вышло обновление драйверов (именно осенью было)

а так вполне можно прошивать китайским клоном USBASP, у меня он тоже есть
правда со студией он у меня не работает, только со сторонними программами


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 25 янв 2015, 03:10 
Здравствуйте!

Зарегистрирован: 25 янв 2015, 00:56
Сообщения: 3
Ну вроде с 4-й студией все забегало...
Спасибо, кто откликнулся)))


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 28 фев 2015, 17:29 
Здравствуйте!
Аватара пользователя

Зарегистрирован: 23 окт 2014, 19:22
Сообщения: 2
Весь смысл сборки этого программатора был в использовании с 6й студией. На 4й и JTAG работает. Кто-нть победил с шестеркой?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 02 мар 2015, 15:16 
Старожил

Зарегистрирован: 16 авг 2012, 23:27
Сообщения: 1372
Откуда: Москва
У меня на 6 студии перестал работать самодельный AVRISP-MKII, симптомы были такие - при попытке прошить студия предлагала обновить прошивку программатора, но естественно с клоном это не прокатывало. Погуглил, нашёл новую прошивку для клона, обновил, теперь всё работает.

Прошивку брал тут: http://tom-itx.no-ip.biz:81/~webpage/boards/USBTiny_Mkii/USBTiny_Mkii_index.php
Но есть нюанс, существуют разные вариации схемы клона, как по задействованным пинам так и по частоте кварца, прошивки естественно у них разные.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 16 авг 2015, 04:22 
Здравствуйте!

Зарегистрирован: 15 авг 2015, 23:50
Сообщения: 1
Откуда: Ukraine
Здравствуйте, уважаемые форумчане.
Хочу поделиться решением проблемы, суть которой описана в начале темы.
Речь идет об отказе работать последних версий среды Atmel Studio с клонами
программатора AVRISP mkII. На момент написания поста это версия
Atmel Studio 6.2 sp2 (build 1563).

На моем компьютере с установленной Windows 8 x64 это проявилось
следующим образом (скрины в спойлере):
Show Unable to connect to tool AVRISP mkII (000200212345)

Или же Atmel Studio вовсе не хочет признавать клон и в упор не видит программатор.

Несколько слов о моем клоне AVRISP mkII:
Аппаратная часть: контроллер ATMEGA16U2 (используется с Arduino UNO R3), идея взята отсюда.
Программная часть: переделан под ATMEGA16U2 и скомпилирован в Linux открытый проект LUFA Project.

Политика Atmel касаемо неоригинальных средств отладки известна и, как правило, проявляется в "программных" способах борьбы с подделками.
Данный пример как раз демонстрирует такой случай. Но, не смотря на усердные старания Atmel, побороть ментальность славян к "халяве" не удается. :)

Теперь ближе к делу. Проводя эксперименты с разными версиями Atmel Studio (далее AS) удалось определить, что версия AS не старше 6.2 (build 1153) прекрасно работает с клонами AVRISP mkII. Только необходимо следить за тем, чтобы версия ПО программатора была актуальной. Например, на данный момент актуальная версия 1.17. О том, как эту версию можно изменить, доходчиво описано здесь. Поэтому можно смело качать версию AS 6.2 (build 1153) с сайта Atmel и спокойно пользоваться клоном программатора AVRISP mkII.
Но все же представляет интерес разобраться, почему же не признает клоны AVRISP mkII среда AS старше 6.2 (build 1153), например AS 6.2 sp2 (build 1563), или же AS 6 (Version: 6.2.1502 - Service Pack 1), как у автора этой темы. Известно, что для обновления ПО средств отладки у AS отвечает консольное приложения atfw (Atmel Studio Firmware upgrade tool).
Его местонахождение (для Windows 8 x64) следующее: C:\Program Files (x86)\Atmel\Atmel Studio 6.2\atbackend. Запускается в командной строке с соответствующими параметрами. Пример показан ниже.
Show atfw -V
Так вот, приложение atfw как раз и делает проверку версии ПО подключенного программатора (может быть делается попытка обновления ПО, но не важно) во время программирования стандартными средствами AS. Если попытаться это сделать вручную, посредством atfw, получим следующее:
Show atfw -t avrispmkii -r (для AS 6.2 sp2 (build 1563))

Для установленной среды AS 6.2 (build 1153) такая проверка заканчивается успешно:
Show atfw -t avrispmkii -r (для AS 6.2 (build 1153))

Теперь становится понятным, в чем причина описываемой проблемы. Все дело в более новой версии приложения atfw.
Таким образом, для решения проблемы необходимо в исполняемых файлах Atmel Studio старше версии 6.2 (build 1153) восстановить
приложение atfw более старой версии, но не старше 1.11.5109. Это можно сделать несколькими способами. Например, можно скопировать
полностью папку atbackend из AS 6.2 (build 1153) и заменить ее в AS более новых версий. Но можно сделать проще.
Необходимо заменить не всю папку atbackend, а только dll-библиотеки, которые в ней есть.
Папка atbackend с необходимыми файлами прикреплена к посту.

В результате замены получаем нормальную работу клона программатора AVRISP mkII в новых версиях AS:
Show Вуаля!

Также необходимо позаботиться о USB-драйверах. Ставить нужно те драйвера, которые идут в комплекте с инсталлятором AS.
Для самой новой версии AS нужно установить последние версии драйверов. Их можно отдельно скачать с сайта Atmel. Для более старых версий среды AS может понадобиться откат на более старые версии драйверов. Если же этого не сделать, также может проявиться описываемая проблема с работой клона AVRISP mkII.

На этом у меня все. Надеюсь, мои рекомендации станут полезными.

P.S. Может быть в atbackend не нужно менять все подряд dll-ки, а только некоторые. Но у меня не было времени на дополнительные эксперименты, поэтому предлагается проверенный способ с заменою всех dll-ок. Если кто захочет, может найдет необходимые dll.
Также должен добавить, что описанная методика подходит и для других операционных систем Windows. Так, например, выше описанные рекомендации проверены в Windows XP SP3, запущенной с виртуальной машины VMware Workstation.

atbackend.rar + screenshots.rar


Последний раз редактировалось sergey378 16 авг 2015, 12:46, всего редактировалось 6 раз(а).

Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 16 авг 2015, 10:48 
Старожил

Зарегистрирован: 20 мар 2013, 11:27
Сообщения: 4229
Браво!)


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 24 авг 2015, 06:33 
Свой человек

Зарегистрирован: 29 июн 2011, 12:30
Сообщения: 150
бурные аплодисменты - спасибо!


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 05 ноя 2015, 19:27 
Здравствуйте!

Зарегистрирован: 05 ноя 2015, 19:20
Сообщения: 1
Добрый день. Установил сегодня Atmel Studio v. 6.2.1563 ServicePack2. Беда такая же. Проблема в том, что не могу скачать архив "atbackend.rar + screenshots.rar". Не мог бы кто-нибудь перелезалить заново или на почту мне скинуть? Буду премного благодарен.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Прошу помочь с AVRISP-MKII
СообщениеДобавлено: 17 фев 2017, 18:56 
Здравствуйте!

Зарегистрирован: 17 фев 2017, 18:49
Сообщения: 1
Здравствуйте!
Буду очень признателен за помощь в получении архива, ссылку на который выкладывали в этой теме.

Если перейти по ссылке, то на сайте файлообмена необходимо "ввести ключ" (я так понимаю это для получения ссылки для скачивания).
Подскажите, пожалуйста, ключ, или перезалейте архив.
Спасибо!


sergey378 писал(а):


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 12 ] 

Часовой пояс: UTC + 5 часов


Кто сейчас на конференции

Сейчас этот форум просматривают: neiver


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB