Easyelectronics.ru

Электроника для всех
Текущее время: 17 окт 2018, 21:51

Часовой пояс: UTC + 5 часов



    • JLCPCB - Прототипы 10 PCBs всего за 2$ (100*100mm, 2-layer)
    • Как мы делаем платы, смотрите на YouTube
    • Крупнейшая китайская фабрика прототипов. 300000+ заказчиков и 10000+ заказов в день!
    • LCSC - Крупнейший китайский онлайн магазин комплектующих.

Начать новую тему Ответить на тему  [ Сообщений: 29 ]  На страницу Пред.  1, 2
Автор Сообщение
 Заголовок сообщения: Re: Atmega88 + UART = проблема
СообщениеДобавлено: 25 окт 2012, 18:18 
Старожил

Зарегистрирован: 10 июн 2011, 23:01
Сообщения: 2978
sim писал(а):
не всё так фатально :) Главное чтобы уплыла не более чем на 10%, чтобы стоп бит не налез на последний бит данных и наоборот. Если в передаче будет пауза, следующий старт бит встанет как надо, синхронизация восстановится.

бит сэмплируется по середине. Чтобы перестало работать достаточно и 5% ухода.
старт бит и так всегда встаёт как надо, так как от него и идёт вся битовая синхронизация внутри байта, добавление пауз между байтами ничего не изменит.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Atmega88 + UART = проблема
СообщениеДобавлено: 29 окт 2012, 23:35 
Старожил

Зарегистрирован: 23 ноя 2010, 20:08
Сообщения: 1099
Откуда: тебя ебёт?
Хозяйке на заметку: который хитрый - тот начинает проверку последовательного интерфейса не с красивого "Hello World!!!", а c простеньких 0b10000000, 0b10001000, 0b10101010...
Show


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Atmega88 не работает UART
СообщениеДобавлено: 30 июн 2014, 18:03 
Здравствуйте!

Зарегистрирован: 30 июн 2014, 17:53
Сообщения: 1
На Atmega88 помогла установка фьюза CKDIV8 который по умолчанию сброшен и делит частоту на 8. Сразу все заработало как часы даже с внутренним генератором. Спасибо за помощь.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Atmega88 + UART = проблема
СообщениеДобавлено: 10 июл 2018, 09:44 
Заглядывает иногда

Зарегистрирован: 07 фев 2014, 15:45
Сообщения: 120
Я програмный UART atmega8 (просто TX и земля) для дебаггинга делал. Также на attiny85 без кварца - всё работало


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 29 ]  На страницу Пред.  1, 2

Часовой пояс: UTC + 5 часов


Кто сейчас на конференции

Сейчас этот форум просматривают: _pv, anakost, baton1, remontsofta


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB