Easyelectronics.ru

Электроника для всех
Текущее время: 16 фев 2019, 00:20

Часовой пояс: UTC + 5 часов




Начать новую тему Ответить на тему  [ Сообщений: 2 ] 
Автор Сообщение
 Заголовок сообщения: STM32 при отладке JTAG в дизасме какие-то левые команды....
СообщениеДобавлено: 22 июл 2015, 13:47 
Только пришел

Зарегистрирован: 01 апр 2015, 09:40
Сообщения: 9
Подробнее о проблеме, начал изучать ARM купил себе платку STM32F102C8T6:
Show

Boot.s и LD использовал из STM Сube. В качестве IDE eclipse+WinArm(gcc)+\yagarto\bin\arm-none-eabi-gdb.exe
Прикладываю boot:
Show

Сюда-же LD:
Show

И .map на всякий случай.:
Show

Скрин
Show

JTAG g-link segger....


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: STM32 при отладке JTAG в дизасме какие-то левые команды....
СообщениеДобавлено: 22 авг 2015, 17:23 
Старожил
Аватара пользователя

Зарегистрирован: 11 фев 2015, 18:08
Сообщения: 211
Ну и в чем проблема?
Просто отладчик воспринимает векторную таблицу как код... Она не исполняется, а служит указателем перехода на обработчик. Т.к. у вас нет большинства обработчиков, то и команда одна и та же - идет на Default_Handler.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 2 ] 

Часовой пояс: UTC + 5 часов


Кто сейчас на конференции

Сейчас этот форум просматривают: PRC


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB